ServiceTitan Impaired Functionality
Resolved
Jun 18 at 10:26am CDT
Service Titan have now resolved invoicing issues
Affected services
ServiceTitan Scheduling
ServiceTitan Estimating
Updated
Jun 17 at 12:33pm CDT
ServiceTitan have resolved the scheduling/start time issues.
Affected services
ServiceTitan Scheduling
ServiceTitan Estimating
Updated
Jun 07 at 02:56pm CDT
ServiceTitan continue to report they are working to resolve these issues.
Affected services
ServiceTitan Scheduling
ServiceTitan Estimating
Updated
May 28 at 10:54pm CDT
Service titan continues to report they are working on the issues.
Affected services
ServiceTitan Scheduling
ServiceTitan Estimating
Created
May 23 at 08:42pm CDT
ServiceTitan has acknowledged platform issues which are impacting MIK franchisees at this time.
== Estimate Proposals ==
We are aware that estimate proposal creation is not functional on desktop for the majority of the network. The vendor has acknowledged this issue. Their present estimated date to resolve is June 16th 2024.
== Call Booking Start Times Change ==
We are aware that start times are changing for select franchisees uncommanded. The vendor has acknowledged this issue. Their present estimated date to resolve is June 16th 2024.
Affected services
ServiceTitan Scheduling
ServiceTitan Estimating